Hercules Dev Machines are experiencing issues
Resolved·Partial outage

Resolved

Sat, Nov 29, 2025, 03:22 AM
(1 week ago)
·
Affected components
Updates

Resolved

Resolved

Sat, Nov 29, 2025, 03:22 AM

Identified

The Fly.io outage has started once again.

We are working directly with Fly to resolve these issues and will update when we know more.

Sat, Nov 29, 2025, 02:31 AM(51 minutes earlier)

Resolved

The issue has been resolved.

To summarize:
1. Our underlying Dev Machine provider, Fly.io, had an outage
2. This is the 4th time in the last 30 days
3. We are frustrated and we are sure you are too
4. It is a top priority for us to migrate off Fly in the coming week

We apologize for these issues

Fri, Nov 28, 2025, 11:51 PM(2 hours earlier)

Monitoring

Dev Machines issues are decreasing, however, are still occurring sporadically. We expect the issues to be entirely resolved within the next 30 minutes

Fri, Nov 28, 2025, 11:44 PM

Monitoring

Hercules' underlying Dev Machine provider is still facing an outage. Please see the Fly.io status page for updates: https://status.flyio.net/

Everything else on Hercules continues to work including your published apps.

This is the 4th time Fly has had an outage in the last month. We are as unhappy as your are. We are going to migrate off them next week and we will make sure these outages never happen again.

Fri, Nov 28, 2025, 11:00 PM(44 minutes earlier)

Identified

The issue has restarted. We are actively following https://status.flyio.net/ for updates

Fri, Nov 28, 2025, 10:15 PM(44 minutes earlier)

Resolved

The incident has been resolved.

This is about the 5th time we have had Dev Machine issues in the last month due to an outage for our underling provider. We are incredibly frustrated and can imagine you (the customer) are too.

We are going to prioritize migrating our Development Machines to another more stable platform.

Our apologies once again for these issues.

Fri, Nov 28, 2025, 09:35 PM(39 minutes earlier)

Identified

What happened?

Our underlying Dev Machine provider, Fly.io, has once again had an outage. See https://status.flyio.net/incidents/2c8mdf1b5wqs

We are working with them to resolve the issue.

What isn't working?

Hercules Dev Machines are failing to load.

What is working?
Everything else is working.

  • Published apps still work

  • Your data is safe

When will this be fixed?

We will update as soon as we know more

Fri, Nov 28, 2025, 09:24 PM(11 minutes earlier)