The Hercules Dev Machine issues have been resolved.
The issue was our underlying dependency, NPM, was having issues, likely related to issues by its parent company, GitHub.
NPM is relied upon by millions of companies and 10s of millions of developers. It is concerning that it had issues. We are actively going to investigate how to make our platform more redundant to these issues in future.
We apologize for these issues
Resolved
The Hercules Dev Machine issues have been resolved.
The issue was our underlying dependency, NPM, was having issues, likely related to issues by its parent company, GitHub.
NPM is relied upon by millions of companies and 10s of millions of developers. It is concerning that it had issues. We are actively going to investigate how to make our platform more redundant to these issues in future.
We apologize for these issues
Identified
What isn't working?
Hercules dev machines are not working
Why?
It appears that Hercules' dependency, NPM, is facing issues. We are investigating the underlying cause and are trying to rectify asap.
What is working?
All published apps continue to work
Your app code is safe
All other features on the Hercules platform including login, team management, etc
Our next steps
We are continuing to investigate the underlying issue and will hopefully have a resolution within the next 30 minutes. We will continue to publish updates as we learn more
What you should do
Please hold off developing on Hercules for the next ~15 minutes
Follow this status page for updates