GitHub has been fully restored and all Hercules services are now working normally.
New app creation is operational
Dev Machines are running at normal speed
All other services continue to work as expected
Thank you for your patience during the outage.
Resolved
GitHub has been fully restored and all Hercules services are now working normally.
New app creation is operational
Dev Machines are running at normal speed
All other services continue to work as expected
Thank you for your patience during the outage.
Monitoring
Update: GitHub Recovery
GitHub is starting to recover and we are monitoring the improvements closely.
Current Status:
GitHub services are gradually coming back online
We are monitoring the ability to create new apps and will update once confirmed working
What's Working:
Existing apps continue to work normally
Previously published apps remain operational
Login and app management functions continue as usual
Next Steps:
We will continue to monitor GitHub's status and test our services as they recover. We'll provide another update once new app creation is fully restored. Thank you for your patience.
Retry
Investigating
Hercules' dependency, GitHub, is down: https://www.githubstatus.com/
What isn't working?
Users are not able to create new apps.
Why?
The template code Hercules uses for new apps is stored in GitHub. GitHub is currently down.
What is working?
Existing apps still work but the Dev Machines may be slow
Everything else including previously published apps, login, app management etc
Next steps
We are continuing to monitor the situation. We are currently unable to make any updates because our code is also stored in GitHub and GitHub is down. We will continue to publish updates as we learn more